ノート:クラス変数

話題追加

静的フィールドに改名提案編集

静的フィールドに改名提案します。その他の候補としては、staticフィールド静的変数を考えています。 --hsz 2007年3月20日 (火) 11:48 (UTC)返信[返信]

改名すべきだという理由を詳しく説明していただけますか。静的フィールドだとJavaやC#に限った名称になり、オブジェクト指向の用語としてはクラス変数が中立でよいと思うのですが。--fryed-peach 2007年3月20日 (火) 12:06 (UTC)返信[返信]
そうですか。元の英語名ではstaticなフィールドはstatic fieldという名前になっていることがまず第一の理由です。en:field (computer science)でもその名前が使われていますその英語の記事では「A static field (also called class variable)」と書いてあります)。「オブジェクト指向といえばJava」といわれるようになり、Javaで使われている用語を、データベースUMLなどの分野でも使うようになってきたことも、理由に挙げられます。ただし、UMLではクラススコープという言葉が使われてはいます。Javaの解説書にもクラス変数という用語がつかわれているものまるため、改名しない方が良いというのであれば、撤回もしてみます。こんなことをいうとおかしいかも知れないですが、実は言うと、改名を強く希望しているわけではないのです。メソッド (計算機科学)のほうでは静的メソッドなどというセクションを作ってしまいましたが、結局、クラス変数のままで改名提案を撤回することもあるかもしれません。--hsz 2007年3月20日 (火) 13:09 (UTC)返信[返信]
英語版のその記事ではおそらく、項目名が field なので static field という呼び方を優先しているのではないかと思います。英語版でもen:Static variableでは class variable と呼んでいます。静的といった場合は変数がプログラムの実行中ずっと存在することを、クラス変数といった場合はクラスに所属することを強調しているので、ニュアンスも違うものと思います。特に静的変数という名前だと、記事の方向性が大きく変わってしまうので反対します。ついでに、グーグルの検索結果数だと クラス変数 > 静的フィールド です。--fryed-peach 2007年3月21日 (水) 04:26 (UTC)返信[返信]
改名提案を撤回しました。--Hsz 2007年3月25日 (日) 10:48 (UTC)返信[返信]
ページ「クラス変数」に戻る。